Searched hist:8874 (Results 1 - 2 of 2) sorted by relevance

/gem5/src/mem/ruby/system/
H A DRubyPort.hh8874:9e2a4cf89be6 Fri Mar 02 09:16:00 EST 2012 Andreas Hansson <andreas.hansson@arm.com> Ruby: Rename RubyPort::sendTiming to avoid overriding base class

This patch renames the sendTiming member function in the RubyPort to
avoid inadvertently hiding Port::sendTiming (discovered through some
rather painful debugging). The RubyPort does, in fact, rely on the
functionality of the queued port and the implementation merely
schedules a send the next cycle. The new name for the member function
is sendNextCycle to better reflect this behaviour.

In the unlikely event that we ever shift to using C++11 the member
functions in Port should have a "final" identifier to prevent any
overriding in derived classes.
H A DRubyPort.cc8874:9e2a4cf89be6 Fri Mar 02 09:16:00 EST 2012 Andreas Hansson <andreas.hansson@arm.com> Ruby: Rename RubyPort::sendTiming to avoid overriding base class

This patch renames the sendTiming member function in the RubyPort to
avoid inadvertently hiding Port::sendTiming (discovered through some
rather painful debugging). The RubyPort does, in fact, rely on the
functionality of the queued port and the implementation merely
schedules a send the next cycle. The new name for the member function
is sendNextCycle to better reflect this behaviour.

In the unlikely event that we ever shift to using C++11 the member
functions in Port should have a "final" identifier to prevent any
overriding in derived classes.

Completed in 57 milliseconds